Загрузка...

Как установить моды на The long dark

Подробная инструкция по установке модов на игру The long dark, начиная с версии 1.79 и выше

  • Alt

Наконец-то мы дождались это знаменательного момента Yahoo моды на The long dark постепенно начинают работают для актуальной версии игры. Выражаем огромную благодарность разработчикам модов: WulfMarius, zeobviouslyfakeacc, Xpazeman и FINDarkside.

Функции отправки телеметрии и сообщений об ошибках должны быть отключены!

Перед тем как устанавливать систему поддержки модов, загрузите игру и убедитесь, что у Вас отключены функции отправки данных телеметрии и сообщений об ошибках:

Главное меню >>> Настройки >>> Личные данные

Отключение функции отправки телеметрии и сообщений об ошибках в The long dark

Далее, необходимо скачать файл MelonLoader.Installer.exe (v 0.6.2 Open-Beta от 10.01.2024).

С новой версией MelonLoader 0.6.2 возникли сложности и большинство модов сейчас выпускают с расчетом на предыдущую версию - 0.6.1. До решения проблем, рекомендуется пока не обновлять MelonLoader или вернуть предыдущую версию (при установке ML есть возможность выбора версии).

Так как это АЛЬФА версия, в настройках ML (вкладка Settings) необходимо установить галочку напротив Show ALPHA Pre-Releases, чтобы версия 0.6.0 стала доступна для установки.

Обратите внимание, что программа находится в стадии открытого бета тестирования и, в настоящий момент, не работает на Windows 7

Установка MelonLoader

Файл находится в zip-архиве, соответственно, его нужно распаковать и запустить. Место, где будет располагаться этой файл, значения не имеет. После запуска MelonLoader, необходимо нажать на кнопку «Select» и указать программе путь до запускающего файла игры – «tld.exe» и нажать на кнопку «Открыть»

Программа MelonLoader.Installer для игры The long dark

Где искать файлы игры, если она куплена в Steam, можно посмотреть в этой статье.

Выбор запускающего файла tld.exe для игры The long dark

Далее, необходимо нажать на кнопку «Install» и дождаться окончания процесса установки.

Установка программы MelonLoader, для The long dark, прошла успешно

Если MelonLoader отказывается работать, убедитесь, что на Вашем компьютере установлены NET Framework 6.0 (Desktop Runtime) и Microsoft Visual C++ 2015-2019 Redistributable.

Проверьте, чтобы в используемых путях отсутствовали буквы русского алфавита.

Обновление / Удаление MelonLoader

Для того чтобы обновить или удалить систему поддержки модов, необходимо еще раз запустить программу MelonLoader и повторить действия, которые выполнялись при ее установке:

  • нажать на кнопку «Select»
  • указать путь до запускающего файла игры – «tld.exe»
  • нажать на кнопку «Открыть»

Далее:

  • для обновления – нажмите на кнопку «UpDate»
  • для удаления – нажмите на кнопку «Un-Install»

Если у Вас уже установлена последняя версия MelonLoader, то вместо кнопки «UpDate» будет «Re-Install» т.е. переустановить.

Обновление или удаление программы MelonLoader, для The long dark

Установка модов

Подготовительная часть закончилась, теперь приступаем к установке самих модов.

Большинство модов устанавливаются в папку «Mods», которая располагается в основном каталоге игры. Если такой папки у Вас нет – создайте ее самостоятельно.

Папка Mods, для установки модов, в основном каталоге игры The long dark

На данный момент, автоматический способ установки (как это было ранее – для версии 1.56) недоступен. В связи с этим, на странице с общим перечнем модов, появилась возможность скачать последние версии тех из них, которые разработчики смогли адаптировать под актуальную версию игры.

Общий перечень всех известных модов, с их описанием, можно посмотреть на этой странице

Для установки мода необходимо скачать соответствующий ему файл. Он находится в zip-архиве, соответственно, необходимо будет его распаковать и поместить содержимое архива в папку «Mods».

>>> Не оставляйте в данной папке архивы! <<<

После этого можно запускать игру и наслаждаться новым функционалом Wink

Установка некоторых модов отличается от стандартной. В этом случае процедура установки представлена в описании такого мода.

Во время загрузки игры будет появляться дополнительное окно. Не пугайтесь – это нормально.

Дополнительное окно при запуске The long dark с поддержкой модов

Для работы некоторых модов, которые имеют собственные настройки, необходима дополнительная библиотека «ModSettings». Рекомендуется сразу ее установить и больше не вспоминать про этот вопрос. Библиотека устанавливается как обычный мод, путем копирования содержимого архива в папку «Mods».

Для работы модов, которые добавляют в игру дополнительные предметы, например Northfolk Clothing Pack или Food-Pack, необходимы дополнительные библиотеки «Mod Component», «Localization Utilities» «Gear Spawner» и «Crafting Revisions». Таких модов немного, но, если Вы планируете их использовать, можно сразу установить необходимые компоненты. Библиотеки устанавливаются как обычные моды, путем копирования содержимого архивов в папку «Mods». В описании каждого мода присутствует информация о необходимости дополнительных библиотек, если такая потребность имеется.

Если Вам необходимо использовать мод который не поддерживается актуальной версией игры, тогда можно воспользоваться Капсулой времени (инструкция на этой странице), установить версию 1.56 и использовать любой имеющийся мод.

Подробную инструкцию по установке модов на версию 1.56 можно посмотреть здесь

Epic Games

В феврале 2023 года разработчик с ником Xpazeman выпустил тестовую версию плагина, который позволяет запускать актуальные моды в игре The long dark, купленной через Epic Games. Данный плагин отключает Epic Online Services поэтому при запуске Melon Loader игра не будет вылетать, однако, одновременно с этим, потеряются игровые достижения.

Установка:

  • Скачайте архив с плагином и распакуйте его в любом месте;
  • Файл «TLDEpicGamesModCompat.dll» поместите в папку: TheLongDark \ Plugins;
  • При первом запуске игры в папке Mods будет создан файл TLDEOSBypasser.dll.

Важные моменты:

Плагин отключит возможность получить доступ к дополнительному контенту: Wintermute и TFTFT т.к. не будет работать служба для проверки прав собственности. Система будет показывать, что у Вас нет прав на дополнения даже если Вы их приобретали.

Удалите плагин из папки Plugins, чтобы получить доступ к дополнениям или использовать загружаемый контент.

Плагин предназначен для использования с версией TLD 2.06 - 2.16 и ML 0.6.0 - 0.6.1, соответственно ему понадобится 6 версия Net Framework для корректной работы. Также он будет поддерживать только те моды, которые адаптировали для работы с TLD 2.06 - 2.16.

Обновление модов

В конце июня 2021 года, один из разработчиков модов - «ds5678» очень сильно упростил алгоритм их использования в игре The long dark. В июне 2023 года другой разработчик модов «STBlade» доработал плагин, чтобы он работал с актуальной версией игры. Теперь моды могут обновляться автоматически. Для этого необходимо скачать архив с плагином:

распаковать его в любом месте и поместить файл «AutoUpdatingPlugin.dll» в папку «TheLongDark \ Plugins». После установки плагина, в процессе загрузки игры, система самостоятельно будет проверять актуальность используемых модов и, в случае необходимости, обновлять их до новых версий.

Удаление модов

Чтобы удалить какой-либо из модов, необходимо просто убрать его из папки «Mods». При наличии большого количества модов бывает сложно вспомнить какие именно файлы отвечают за тот или иной мод. В данном случае могу порекомендовать скачать мод еще раз, поместить его в отдельную папку, посмотреть из каких файлов он состоит и убрать их из основной папки с модами.

Некоторые моды создают в папке «Mods» дополнительный файл с одноименным названием и расширением «*.json» (как правило, в нем содержится информация о настройках мода). Если Вы окончательно удаляете мод и не планируете использовать его в дальнейшем - этот файл тоже необходимо удалить. Если Вы временно деактивируете какой-то из модов, то данный файл лучше оставить, чтобы потом не пришлось заново выставлять настройки.

Последние обновления статей с модами

Как установить моды на The long dark - 4 месяца 6 дней назад
Мод Developer Console на игру The long dark - 4 месяца 2 недели назад
Описание мода Food-Pack на игру The long dark - 5 месяцев 6 дней назад

Надеюсь смог помочь. Пусть согревает Вас дух огня в холодные зимние ночи! Hi!

Рекомендуемые статьи

Комментарии

  • Alt
    пт, 29/07/2022 - 02:51 ответить
    Я установил MelonLoader v0.5.4 и когда запустил игру антивирус убрал некоторые файлы в карантин, я восстановил их, но в игре не было модов которые требовали доп. моды, и в MelonLoader было написано: Some Melons are missing dependencies, which you may have to install. If these are optional dependencies, mark them as optional using the Melon Optional Dependencies attribute. This warning will turn into an error and Melons with missing dependencies will not be loaded in the next version of MelonLoader и ошибки: 'ModSettings' is missing the following dependencies: - 'Assembly-CSharp' v0.0.0.0 - 'UnityEngine.CoreModule' v0.0.0.0 - 'UnhollowerBaseLib' v0.4.15.4 - 'Il2Cppmscorlib' v0.0.0.0 - 'UnityEngine.PhysicsModule' v0.0.0.0 Начал переустанавливать MelonLoader, но Current доходит до 100%, а Total до 50% и выдает ошибку: Unable to remove Existing MelonLoader Folder! Make sure the Unity Game is not running or try running the Installer as Administrator. Даже когда запускал от имени администратора выскакивала эта ошибка и папка MelonLoader в корне игры осталась, но удалить ее я не могу Помогите кто нибудь =(
    • Alt
      вт, 02/08/2022 - 10:15 ответить
      Странная ситуация. Много раз переустанавливал ML и антивирус никогда не ругался (пользовался Каспером, потом перешел на DrWeb). Вероятно восстановления удаленных файлов оказалось недостаточно, антивирус не дал создать необходимые зависимости в имеющихся библиотеках. Удалите ML. При повторном запуске дистрибутива появляется кнопка для удаления. Отключите антивирус и установите ML повторно. Большинство проблем с установкой ML всегда были связаны с отсутствием NET Framework 4.8 и Microsoft Visual C++ 2015-2019 Redistributable, убедитесь, что они у вас есть.
  • Alt
    пт, 30/09/2022 - 09:31 ответить
    MelonLoader обновлен до версии 0.5.5 Open-Beta
  • Alt
    пт, 14/10/2022 - 14:40 ответить
    на версии v302 alpha не работает !!! в консоле ошибка красным цветом и закрывает и всё
    • Alt
      Данная система поддержки модов разрабатывалась под версию 1.79 и дорабатывалась по мере обновления игры. Для более ранних версий игры (1.56 и ниже) использовалась другая система поддержки модов, но она тоже появилась гораздо позже версии v302 alpha. Изучите статью "Как установить моды на The long dark 1.56 и ниже". В те времена алгоритмы игры изменялись не так сильно, может быть получится запустить таким способом.
  • Alt
    вс, 30/10/2022 - 02:10 ответить
    MelonLoader обновлен до версии 0.5.7 Open-Beta
  • Alt
    Можно ли установить дополнительные моды после начала новой игры?
    • Alt
      чт, 03/11/2022 - 23:16 ответить
      Большинство модов можно устанавливать и удалять в любой момент. Все важные особенности указываются в описании конкретного мода.
  • Alt
    Спасибо
  • Alt
    Kent
    вт, 06/12/2022 - 22:31 ответить
    Как открыть файл, когда запускаю предлагает открыть в программах
    • Alt
      вт, 06/12/2022 - 22:38 ответить
      Структура игры кардинально изменилась, соответственно нужно полностью переделывать всю систему поддержки модов, а на это нужно время. Набираемся терпения и ждем. Если игра отказывается запускаться, тогда удалите MelonLoader до его обновления под версию 2.03
  • Alt
    Всем привет! Дух огня Вам и вашей команде отдельный салют! Очень жду скорейшего обновления в TLD).
  • Alt
    Андрей Сталкер
    пн, 12/12/2022 - 17:09 ответить
    При установке MelomLoader при первом же запуске вылетает игра, модов не ставил, отправку данных отключил. В чем может быть проблема ?
    • Alt
      пн, 12/12/2022 - 18:53 ответить
      Установите версию 2.02 через капсулу времени и все заработает. Для версии 2.04 моды пока недоступны.
  • Alt
    Андрей Сталкер
    вт, 13/12/2022 - 04:02 ответить
    При установке MelomLoader при первом же запуске вылетает игра, модов не ставил, отправку данных отключил. В чем может быть проблема ?
  • Alt
    ср, 14/12/2022 - 21:49 ответить
    Обращение разработчиков модов для The long dark Поддержка модов немного откладывается т.к. после выхода обновления 2.03 игра стала использовать обновленную версию движка Unity, которая пока не поддерживается актуальной версией MelonLoader. Нам необходимо, как минимум, несколько недель (а возможно и больше), чтобы адаптировать систему поддержки модов под новую реальность. Чтобы продолжать играть с модами прямо сейчас, воспользуйтесь возможностями капсулы времени, загрузите версию 2.02 и продолжайте наслаждаться всеми дополнениями, разработанными нашей командой. Отдельно хочу заверить Вас, что поддержка модов не прекращается и будет продолжаться еще долгое время. Мы в любом случае справимся с этими трудностями, весь вопрос только в том, сколько для этого понадобится времени.
  • Alt
    сб, 17/12/2022 - 08:36 ответить
    после последнего обновления игры и добавления DLS. MelonLoader не работает, при запуска игра просто вылетает, в итоге как я понял пока MelonLoader не будет работать с новой версией то и моды установить не возможно.
    • Alt
      вс, 18/12/2022 - 01:22 ответить
      Несколько раз выше уже отвечали. Ждем пока моды адаптируют или загружаем версию 2.02 через капсулу времени.
  • Alt
    пн, 26/12/2022 - 19:12 ответить
    Разработчики модов выпустили АЛЬФА версию MelonLoader 0.6.0, которая поддерживает TLD после выхода Tales From The Far Territory (рекомендую дождаться выхода стабильной версии). Для работы ML дополнительно необходимо установить NET 6.0 (без этого работать не будет). Ссылка на дистрибутив приведена в статье.
    • Alt
      ср, 04/01/2023 - 07:12 ответить
      но пока, к сожалению она тоже не работает:-)
  • Alt
    Nosorock
    пн, 26/12/2022 - 23:25 ответить
    Ребята, вы забыли указать, что для обновления до версии 0,6,0 нужно поставить галочку в установщике на show alpha pre-resises в разделе setings иначе установщик просто не видит версию 0,6,0
  • Alt
    мда
    вт, 27/12/2022 - 12:01 ответить
    кароче не работает, 20 раз туда сюда переустановил по всякому, вылет на загрузке, разница только в появившихся графических косяках на экране загрузки лоадера, лабудянство какое то, неужели проще нельзя сделать, это просто моды на игру..
    • Alt
      Во-первых это Альфа версия, со всеми вытекающими из этого неудобствами. Во-вторых, на данный момент, с текущей версией ML корректно работает только один мод. Лично у меня все заработало с первого раза. По поводу "проще сделать" - покажите пример.
      • Alt
        мда
        вт, 27/12/2022 - 15:14 ответить
        Ты телепат видимо, один мод и с первого раза всё работает. По поводу "покажи пример", сделаю обязательно, как только так сразу, очень оригинальное и полезное замечание, где то я это уже слышал, не раз, не два...
  • Alt
    мда
    вт, 27/12/2022 - 20:12 ответить
    Инсталлятор МЛ 0.6.0 антивир сразу удаляет, не говорю что там вирус. Вообще странно, несколько раз пробовал варианты, удалял, загружал, в итоге антивир стал удалять его сразу на зарузке)) Как буд то версия по ссылке поменялась. А с МЛ 0.5.7 проблем нет. Установил игру 2.02, с МЛ 0.5.7 (скачанный с другого места ибо этот сразу удаляется антивиром) из 10 модов только два не работают (на уменьшение веса и респавн лута в контейнерах). Думается что если и допилят МЛ, то ещё моды придётся подгонять, ждать придётся долго.
    • Alt
      вт, 27/12/2022 - 20:27 ответить
      Моды обязательно придется переделывать, без этого они не будут работать с новой версией MelonLoader.
  • Alt
    Bygyrt
    сб, 07/01/2023 - 14:10 ответить
    В чем прикол? Обычные моды, которые не требуют доп модов типа «ModSettings», «Mod Component» и т.д., работают без проблем. Как только ставлю "ModSettings», игра вылетает на экране ML. Сам ML версии 6.0. Пробовал и 5.7, та же хурма
    • Alt
      сб, 07/01/2023 - 14:28 ответить
      Прикол в том, что структура игры изменилась и всю систему поддержки модов, а также сами моды необходимо переделывать. В настоящий момент корректно работают только 6 модов.
      • Alt
        Bygyrt
        сб, 07/01/2023 - 14:31 ответить
        А поподробнее какие именно работают?
        • Alt
          сб, 07/01/2023 - 14:40 ответить
          Работают те моды, в описании которых указана версия TLD - 2.06. На странице с модами их можно отсортировать по дате обновления и на главной странице представлена информация по последним обновлениям модов.
  • Alt
    Сергей
    сб, 07/01/2023 - 16:07 ответить
    У меня версия игры 1.99. ML -0.5.7 И вдруг после нового года игра перестала загружаться. Отключил ML и игра загрузилась, значит с игрой всё в порядке. Отключил антивирус, проблема осталась. Решил попробовать загружать игру с разными модами и ничего не вышло. Итог: если запускать игру через ML с разными модами, то игра не запускается, если запустить с пустой папкой mods, то запускается. В итоге я выяснил, что не загружается из-за "ModSettings», что с ним не так я не знаю, но проблема именно с "ModSettings».
    • Alt
      вс, 08/01/2023 - 01:40 ответить
      У меня такая же ситуация - перестали работать моды на версии 2.02 ML 0.5.7 (вылетает при загрузке), хотя на версии 2.06 ML 0.6.0 моды работают. Единственное что я сделала это обновила NET Framework до версии 6.0.
  • Alt
    Сергей
    сб, 07/01/2023 - 16:09 ответить
    Проблема с "ModSettings». Версия игры 1.99 ML 0.5.7. Так, что проблема ни с новой версией игры, а именно с "ModSettings»
  • Alt
    мда
    вс, 08/01/2023 - 07:15 ответить
    2.02 ML 0.5.7 всё работает, штук 15 модов стоит, некоторые моды заработали после скачки с xpazeman, там видать более новые версии (мод на вес и автобновление контейнеров). Как вариант, может стоит плагин на автообновление и новые версии модов перестали поддерживать старую версию игры, я этот плагин не ставил.
    • Alt
      вс, 08/01/2023 - 11:56 ответить
      Отличная мысль, Спасибо! Снесла плагин, установила старые версии модов и все заработало.
  • Alt
    пн, 09/01/2023 - 01:35 ответить
    Melon loader ошибка il2cpp.init detour failed Причина устранилась после установки NET Framework до версии 6.0.
  • Alt
    вт, 10/01/2023 - 15:13 ответить
    Как в режиме выживания моды включить? По инструкции запускаются только в режиме выживания.
    • Alt
      Т.к. игру разделили на две составляющие, запускающих файлов теперь тоже два. Чтобы режим истории запускался через ML необходимо пропатчить файл tld.exe в папке tld_dlc\wintermute, но сами моды пока не работают в этом режиме.
      • Alt
        ср, 11/01/2023 - 15:12 ответить
        Прыжок получилось заставить работать. Консоль нет. Блин, надо-то всего лишь рюкзак до 40 кило повысить.
  • Alt
    ALukard
    чт, 19/01/2023 - 15:58 ответить
    Путем отбора выяснил, что виной всему является не ModeSettings, a Mode Component. Удалив его и оставив все остальные, игра наконец-то запустилась. НО: никакие моды кроме Консоли вообще не работают теперь, хоть и установлены и в настройках можно их всех увидеть. Ни поиск на различных языках, ни манипуляции с MelonLoader ни к чему не приводят. Игра качалась и переустанавливалась с различных источников, MelonLoader актуален. Хотя при повторном нажатии на него не видно кнопки "обновить" или "переустановить", только "install", будто впервые устанавливается.
    • Alt
      чт, 19/01/2023 - 18:28 ответить
      В описании каждого мода указано с какой версией TLD и ML он работает. В настоящий момент с актуальной версией игры - 2.06 корректно работают всего десять модов.
  • Alt
    пт, 27/01/2023 - 01:08 ответить
    Столкнулся с такой проблемой при установке ML после нажатия кнопки "install" открывается окно с надписью:System.IO.FileNotFoundException: Could not load or assembly и т.д Подскажите что делать раньше устанавливал все было нормально
  • Alt
    adrianna
    вс, 29/01/2023 - 19:04 ответить
    Я из тех, у кого не работают последние версии MelonLoader'а, и вот что я заметила... При попытке установить его у меня в игре не меняется экзешник, хотя вроде как должен. Дело не в NET Framework 6, который я установила, и не в антивирусе, который я удаляла полностью, это ничего не изменило. Возможно, кто-нибудь выложит куда-нибудь пропатченный MelonLoader'ом экзешник стимовской версии, чтобы проверить, действительно ли дело в этом?
  • Alt
    В очередной раз промониторил западные форумы, к сожалению, типового решения проблемы как не было, так и нет. У тех, кто приобретал игру через Эпик опять ничего не работает, одному помогла глобальная переустановка игры (с удалением ее папки), другому удалось запустить моды после удаления папки MelonStartScreen, расположенной в основном каталоге игры\UserData.
    • Alt
      adrianna
      пн, 30/01/2023 - 01:34 ответить
      Скажите, а у кого патч работает, он всё-таки меняет экзешник игры? Его старые версии вроде бы это делали. И мне кажется странным, что сейчас этого не происходит, он просто добавляет свои файлы в папку с игрой, и всё.
      • Alt
        Запускающий файл не меняется. Относительно него программа находит нужные ей библиотеки, в которые и вносятся изменения. Раньше было так же.

Оставить комментарий