Загрузка...

Как установить моды на The long dark

Подробная инструкция по установке модов на игру The long dark, начиная с версии 1.79 и выше

  • Alt

Наконец-то мы дождались это знаменательного момента Yahoo моды на The long dark постепенно начинают работают для актуальной версии игры. Выражаем огромную благодарность разработчикам модов: WulfMarius, zeobviouslyfakeacc, Xpazeman и FINDarkside.

Функции отправки телеметрии и сообщений об ошибках должны быть отключены!

Перед тем как устанавливать систему поддержки модов, загрузите игру и убедитесь, что у Вас отключены функции отправки данных телеметрии и сообщений об ошибках:

Главное меню >>> Настройки >>> Личные данные

Отключение функции отправки телеметрии и сообщений об ошибках в The long dark

Далее, необходимо скачать файл MelonLoader.Installer.exe (v 0.6.2 Open-Beta от 10.01.2024).

С новой версией MelonLoader 0.6.2 возникли сложности и большинство модов сейчас выпускают с расчетом на предыдущую версию - 0.6.1. До решения проблем, рекомендуется пока не обновлять MelonLoader или вернуть предыдущую версию (при установке ML есть возможность выбора версии).

Так как это АЛЬФА версия, в настройках ML (вкладка Settings) необходимо установить галочку напротив Show ALPHA Pre-Releases, чтобы версия 0.6.0 стала доступна для установки.

Обратите внимание, что программа находится в стадии открытого бета тестирования и, в настоящий момент, не работает на Windows 7

Установка MelonLoader

Файл находится в zip-архиве, соответственно, его нужно распаковать и запустить. Место, где будет располагаться этой файл, значения не имеет. После запуска MelonLoader, необходимо нажать на кнопку «Select» и указать программе путь до запускающего файла игры – «tld.exe» и нажать на кнопку «Открыть»

Программа MelonLoader.Installer для игры The long dark

Где искать файлы игры, если она куплена в Steam, можно посмотреть в этой статье.

Выбор запускающего файла tld.exe для игры The long dark

Далее, необходимо нажать на кнопку «Install» и дождаться окончания процесса установки.

Установка программы MelonLoader, для The long dark, прошла успешно

Если MelonLoader отказывается работать, убедитесь, что на Вашем компьютере установлены NET Framework 6.0 (Desktop Runtime) и Microsoft Visual C++ 2015-2019 Redistributable.

Проверьте, чтобы в используемых путях отсутствовали буквы русского алфавита.

Обновление / Удаление MelonLoader

Для того чтобы обновить или удалить систему поддержки модов, необходимо еще раз запустить программу MelonLoader и повторить действия, которые выполнялись при ее установке:

  • нажать на кнопку «Select»
  • указать путь до запускающего файла игры – «tld.exe»
  • нажать на кнопку «Открыть»

Далее:

  • для обновления – нажмите на кнопку «UpDate»
  • для удаления – нажмите на кнопку «Un-Install»

Если у Вас уже установлена последняя версия MelonLoader, то вместо кнопки «UpDate» будет «Re-Install» т.е. переустановить.

Обновление или удаление программы MelonLoader, для The long dark

Установка модов

Подготовительная часть закончилась, теперь приступаем к установке самих модов.

Большинство модов устанавливаются в папку «Mods», которая располагается в основном каталоге игры. Если такой папки у Вас нет – создайте ее самостоятельно.

Папка Mods, для установки модов, в основном каталоге игры The long dark

На данный момент, автоматический способ установки (как это было ранее – для версии 1.56) недоступен. В связи с этим, на странице с общим перечнем модов, появилась возможность скачать последние версии тех из них, которые разработчики смогли адаптировать под актуальную версию игры.

Общий перечень всех известных модов, с их описанием, можно посмотреть на этой странице

Для установки мода необходимо скачать соответствующий ему файл. Он находится в zip-архиве, соответственно, необходимо будет его распаковать и поместить содержимое архива в папку «Mods».

>>> Не оставляйте в данной папке архивы! <<<

После этого можно запускать игру и наслаждаться новым функционалом Wink

Установка некоторых модов отличается от стандартной. В этом случае процедура установки представлена в описании такого мода.

Во время загрузки игры будет появляться дополнительное окно. Не пугайтесь – это нормально.

Дополнительное окно при запуске The long dark с поддержкой модов

Для работы некоторых модов, которые имеют собственные настройки, необходима дополнительная библиотека «ModSettings». Рекомендуется сразу ее установить и больше не вспоминать про этот вопрос. Библиотека устанавливается как обычный мод, путем копирования содержимого архива в папку «Mods».

Для работы модов, которые добавляют в игру дополнительные предметы, например Northfolk Clothing Pack или Food-Pack, необходимы дополнительные библиотеки «Mod Component», «Localization Utilities» «Gear Spawner» и «Crafting Revisions». Таких модов немного, но, если Вы планируете их использовать, можно сразу установить необходимые компоненты. Библиотеки устанавливаются как обычные моды, путем копирования содержимого архивов в папку «Mods». В описании каждого мода присутствует информация о необходимости дополнительных библиотек, если такая потребность имеется.

Если Вам необходимо использовать мод который не поддерживается актуальной версией игры, тогда можно воспользоваться Капсулой времени (инструкция на этой странице), установить версию 1.56 и использовать любой имеющийся мод.

Подробную инструкцию по установке модов на версию 1.56 можно посмотреть здесь

Epic Games

В феврале 2023 года разработчик с ником Xpazeman выпустил тестовую версию плагина, который позволяет запускать актуальные моды в игре The long dark, купленной через Epic Games. Данный плагин отключает Epic Online Services поэтому при запуске Melon Loader игра не будет вылетать, однако, одновременно с этим, потеряются игровые достижения.

Установка:

  • Скачайте архив с плагином и распакуйте его в любом месте;
  • Файл «TLDEpicGamesModCompat.dll» поместите в папку: TheLongDark \ Plugins;
  • При первом запуске игры в папке Mods будет создан файл TLDEOSBypasser.dll.

Важные моменты:

Плагин отключит возможность получить доступ к дополнительному контенту: Wintermute и TFTFT т.к. не будет работать служба для проверки прав собственности. Система будет показывать, что у Вас нет прав на дополнения даже если Вы их приобретали.

Удалите плагин из папки Plugins, чтобы получить доступ к дополнениям или использовать загружаемый контент.

Плагин предназначен для использования с версией TLD 2.06 - 2.16 и ML 0.6.0 - 0.6.1, соответственно ему понадобится 6 версия Net Framework для корректной работы. Также он будет поддерживать только те моды, которые адаптировали для работы с TLD 2.06 - 2.16.

Обновление модов

В конце июня 2021 года, один из разработчиков модов - «ds5678» очень сильно упростил алгоритм их использования в игре The long dark. В июне 2023 года другой разработчик модов «STBlade» доработал плагин, чтобы он работал с актуальной версией игры. Теперь моды могут обновляться автоматически. Для этого необходимо скачать архив с плагином:

распаковать его в любом месте и поместить файл «AutoUpdatingPlugin.dll» в папку «TheLongDark \ Plugins». После установки плагина, в процессе загрузки игры, система самостоятельно будет проверять актуальность используемых модов и, в случае необходимости, обновлять их до новых версий.

Удаление модов

Чтобы удалить какой-либо из модов, необходимо просто убрать его из папки «Mods». При наличии большого количества модов бывает сложно вспомнить какие именно файлы отвечают за тот или иной мод. В данном случае могу порекомендовать скачать мод еще раз, поместить его в отдельную папку, посмотреть из каких файлов он состоит и убрать их из основной папки с модами.

Некоторые моды создают в папке «Mods» дополнительный файл с одноименным названием и расширением «*.json» (как правило, в нем содержится информация о настройках мода). Если Вы окончательно удаляете мод и не планируете использовать его в дальнейшем - этот файл тоже необходимо удалить. Если Вы временно деактивируете какой-то из модов, то данный файл лучше оставить, чтобы потом не пришлось заново выставлять настройки.

Последние обновления статей с модами

Как установить моды на The long dark - 4 месяца 3 недели назад
Мод Developer Console на игру The long dark - 5 месяцев 1 неделя назад
Описание мода Food-Pack на игру The long dark - 5 месяцев 3 недели назад

Надеюсь смог помочь. Пусть согревает Вас дух огня в холодные зимние ночи! Hi!

Рекомендуемые статьи

Комментарии

    • Alt
      Jaminkle
      пт, 18/08/2023 - 19:36 ответить
      Капец уже всё перепробовал, ничего не помогает у меня лицензия стим(
  • Alt
    Jaminkle
    пт, 18/08/2023 - 19:43 ответить
    Разобрался, помогло только то что устанавливал различные версии подошла только dotnet-sdk-6.0.100-win-x64
    • Alt
      сб, 19/08/2023 - 11:25 ответить
      Отлично! Рад, что у Вас получилось решить вопрос и спасибо, что поделились способом решения.
  • Alt
    asd
    вт, 05/09/2023 - 14:51 ответить
    У кого-то работают моды? ML крашится без каких-либо ошибок при запуске игры
  • Alt
    Влад
    сб, 16/09/2023 - 16:12 ответить
    Установил ML последней версии, потом закинул мод на консоль в папку модс, захожу в игру и консоль не работает, жму F1 и нечего не происходит.....
  • Alt
    пн, 18/09/2023 - 21:58 ответить
    Моды как работали, так и работают. Сложности могут возникнуть после выхода 4 части DLC, но до этого еще дожить надо. Обращайте внимание на вспомогательное программное обеспечение. Больше всего нареканий вызывает NET Framework 6 - пробуйте устанавливать разные сборки. Разработчики рекомендовали версию Desktop Runtime, но у некоторых она не работает, а когда устанавливают другую - все запускается. Читайте комментарии выше, эта тема много раз обсуждалась.
  • Alt
    вт, 19/09/2023 - 15:45 ответить
    Вы не могли бы подсказать - как ни бьюсь, строка Mod Settings в меню не появляется. Правильно понимаю - моды устанавливаю в папку Mods для Wintermute, а melonloader на exe файл общей игры, не Wintermute? Версия игры 2.22, ML 3.0.8
    • Alt
      вт, 19/09/2023 - 22:15 ответить
      В режиме истории моды сейчас работать не будут. После запуска ML ему нужно указывать на файл tld.exe в основном каталоге игры и папка Mods тоже должна располагаться там же. Mod Settings не покажется в меню игры пока в папке mods не появится хотя бы один мод, который в нем нуждается.
  • Alt
    iWATрушка
    чт, 28/09/2023 - 08:55 ответить
    Вчера (27.09.2023) игра обновилась (Steam, TLD c DLC), при запуске игры МL загружается, потом игра вылетает без каких-либо ошибок. Кто решил эту проблему? Подскажите, пожалуйста!
    • Alt
      Гость
      чт, 28/09/2023 - 21:46 ответить
      Писали, что заново нужно переустанавливать MelonLoader и, возможно, придется ждать обновления модов.
      • Alt
        iWATрушка
        пт, 29/09/2023 - 12:25 ответить
        Спасибо большое. Ждать так ждать)))
  • Alt
    ника
    чт, 28/09/2023 - 23:10 ответить
    скачала все по инструкции. игра стимовская. пока папка mods пустая, игра запускается. Как только я кидаю туда моды, при запуске пишет - прекращена работа tld. с чем это может быть связано?((
    • Alt
      вт, 03/10/2023 - 13:29 ответить
      Похожая проблема. Я впервые попыталась установить моды, тоже всё по инструкции. TLD последней версии, при запуске открывается консоль с надписью "il2cpp_init detour failed: Failed to load hostfxr. Please make sure you have installed the .NET 6.0 runtime."
      • Alt
        bg
        пт, 15/12/2023 - 19:56 ответить
        у меня тоже
      • Alt
        пт, 15/12/2023 - 21:39 ответить
        В инструкции написано, что нужно установить NET Framework 6.0, (даже выделено) и консоль вам открытым текстом пишет, что ей требуется "installed the .NET 6.0 runtime." Если установили и опять не работает, пробуйте устанавливать разные сборки. Разработчики рекомендовали Runtime, но бывают исключения. Лично у меня установлена сборка SDK.
  • Alt
    NF204
    чт, 09/11/2023 - 13:08 ответить
    тлд с установленным мелоном запускается на версии без дополнений с новым лутом, соответственно весь этот лут пропадает. как лечить?
    • Alt
      чт, 09/11/2023 - 20:13 ответить
      На Steam версии все должно работать нормально, сложности с дополнениями возникают только на версии от Epic.
  • Alt
    Jabotikaba
    вс, 03/12/2023 - 23:17 ответить
    Загрузка доходит до Ограничение от ответственности, после нажатия на любую кнопку ничего не происходит. Переустановка, запуск от администратора не помогли. Подскажите как исправить данный недуг!
    • Alt
      пн, 04/12/2023 - 23:12 ответить
      Какая операционная система? Какая версия ML? Какая версия TLD? TLD от Steam или Epic?
  • Alt
    Первые вспомогательные библиотеки (Mod Component и Crafting Revisions) уже обновлены для корректной работы с новой версией The long dark - 2.25
  • Alt
    любитель
    сб, 09/12/2023 - 00:28 ответить
    После установки мода Weight Tweaks игра подтормаживает каждые несколько секунд. Как то можно вылечить?
    • Alt
      сб, 09/12/2023 - 19:25 ответить
      Ответ на этот вопрос есть в описании мода. Посмотрите мод Carry Weight, он создан как раз потому, что у разработчика не получилось решить проблемы с производительностью.
  • Alt
    V23871629
    вс, 17/12/2023 - 21:07 ответить
    Не запускается на версию 2.26, вылетает ошибка
  • Alt
    чт, 21/12/2023 - 07:48 ответить
    Уважаемые администраторы, помогите пожалуйста) из всех модов работает только мод на быстрый обыск ящиков, свет в помещениях , и вес. Мод на шишки/касатку/ труп ворона - все появляется в игре, но взаимодействия с предметами нет. Не переходит с одной локации на другую, режим выживания, просто экран загрузки, ждала часами, никак. Сносила игру и устанавливала заново, начинала новые, пробовала играть в старые сохранения. Мелон последняя версия , как и тлд со всеми купленными дополнениями. Как быть, и что делать на знаю. До покупки обнов с ародромом (до которого я так и не попала ,т.к не переходит с локации), все работало отлично , и с модами, и без . Помогите пожалуйста, посоветуйте что нибудь) заранее благодарю)
    • Alt
      Обновите мод Bountiful Foraging и все вспомогательные библиотеки, которые указаны в описании. Сейчас должен работать нормально на TLD 2.26 (беглое тестирование ошибок не показало - шишки подбираются, переход между локациями происходит корректно).
  • Alt
    Juli
    вт, 26/12/2023 - 15:12 ответить
    Прошу о помощи! Не отображаются новые чертежи модов нигде. Я даже версию игры откатила до 2.25 чтобы проверить работу модов этой же версии. Сами предметы модов в мире появляются, но например скрафтить горшок с цветами или сделать палатку или теплое одеяло - не могу. Просто нет чертежей в игре. Основные моды и ML обновила. Каких либо ошибок нет. Что делать?
  • Alt
    ср, 27/12/2023 - 08:43 ответить
    Прошу о помощи! У меня не отображаются новые чертежи модов нигде. Сами моды работают. Предметы появляются, но крафтить например горшок с цветком я не могу. Тот же мод с палатками, предметы вроде ножа нахожу, но сделать палатку нет. Мод со свечами, топить воск могу, но чертежа чтобы сделать свечу нет. Все зависимые моды и ML я обновила. Установила как было указано и Framework, Visual C я тоже обновила. Саму игру даже скачала пиратку 2.25 чтобы проверить.
    • Alt
      Если я правильно понял, речь идет о моде «Indoors Greenery». Обновите его и вспомогательную библиотеку «Modders Gear Toolbox». Перед заменой обязательно удалите старый файл IndoorsGreenery.json, чтобы избежать ошибок. Сейчас должно нормально работать с версией 2.25 и 2.26
      • Alt
        ср, 27/12/2023 - 17:08 ответить
        Благодарю за ответ, я ставила всё новое на чистую игру. У меня не отображаются чертежи не только этого мода. Но и Camping Tools, Candlelight, Cozy Blankets. Я всё удаляла и заново качала и ставила.
        • Alt
          Мод Candlelight нормально работает на TLD 2.26, скачал все заново, запустил и заработало, даже танцев в бубном не понадобилось. Если скачивали с зарубежных ресурсов, то там допущена ошибка - по их сборке, действительно, чертежи не появляются. Остальные сегодня не успел проверить.
        • Alt
          Мод Cozy Blankets также нормально работает с последней версией TLD (2.26), если обновлены все вспомогательные библиотеки.
        • Alt
          Мод Camping Tools немного докрутил, теперь тоже работает на TLD 2.26 Обратите внимание, что ему дополнительно понадобится еще одна библиотека - Examine Actions API
  • Alt
    вс, 14/01/2024 - 00:36 ответить
    Йо, всем салам, вопрос возник, накачал модов, радостный запустил злд, и всё работает Но как только захотел подобрать палку понял, что кнопка интерактива пропала Вопрос, это распространённая проблема или мне надо будет каждый мод проверять на наличии этой ситуации
    • Alt
      вс, 14/01/2024 - 00:41 ответить
      Прочитал, что человек выше столкнулся с похожей проблемой в том же моде, что присутствует у меня, "Bountiful Foraging", но все моды/библиотеки скачаны буквально только что, и новых версий нет
      • Alt
        вс, 14/01/2024 - 16:12 ответить
        Мод "Bountiful Foraging" тестировался перед НГ и сейчас еще раз повторно проверил - все нормально работает на TLD 2.26. Могу предположить, что проблему вызывает какой-то другой мод, который еще не адаптирован под новую версию игры. Скачайте только "Bountiful Foraging", все указанные в его описании компоненты и проверьте работоспособность системы. После этого добавляйте по одному моду и проверяйте все ли корректно работает. Обращайте внимание на описание мода, там указывается версия игры на которой он гарантированно будет работать. Если не сложно, напишите по результату, чтобы другим было проще.
  • Alt
    вс, 14/01/2024 - 12:54 ответить
    Добрый День, подскажите пожалуйста. Можно ли установить "MelonLoader" добавить предметов с помощью "Mod Developer Console", а потом удалить мод и откатить MelonLoader на ваниллу, будут ли работать сохранения?
    • Alt
      вс, 14/01/2024 - 16:14 ответить
      Добрый день! Можно, на Вашем файле сохранения это никак не отразится и все добавленные предметы останутся с персонажем.
  • Alt
    Marvik
    пн, 15/01/2024 - 15:15 ответить
    Добрый день! После обновления игры при использовании любых модов требующих библиотеку ModComponent в меню игрока на закладке "Мастерить" невозможно выбрать ни одного чертежа. Все моды и библиотеки последних версий. Спасибо.
    • Alt
      Добрый день! За последний месяц наблюдаю очень много подобных жалоб и с каждым модом разбираемся отдельно. Выше в комментариях указаны моды которые лично протестировал и убедился в их работоспособности. Гарантировано должны работать только те, у которых в описании указаны последние версии TLD 2.25 или 2.26, Работу всех остальных модов могу гарантировать только для тех версий игры, которые указаны в описании. Какой именно мод не работает у Вас?
      • Alt
        Marvik
        пн, 29/01/2024 - 23:29 ответить
        Не работает с модом Candlelight.
        • Alt
          Какие версии вспомогательных библиотек показывает ML после загрузки и в какую папку установлена игра?
          • Alt
            Marvik
            вт, 30/01/2024 - 23:03 ответить
            Вспомогательные библиотеки: ExamineActionsAPI v1.0.5, LocalizationUtilities v2.0.0, ModData v1.5.2, ModSettings v2.0.0, CraftingRevisions v2.2.2, GearSpawner v2.3.2, ModComponent v6.2.1 Игра установлена в папку C:\Program Files (x86)\Steam\steamapps\common\TheLongDark
          • Alt
            Marvik
            вт, 30/01/2024 - 23:22 ответить
            Прошу прощения. Обновил вспомогательную библиотеку ModComponent до версии 6.2.5 и все заработало. Спасибо.
            • Alt
              Отлично! Приятно слышать, что все работает. Если возникнут сложности с подбором предметов из других модов, в частности Food Pack, перенесите игру в другую (несистемную) папку. Недавно обнаружили эту особенность.
  • Alt
    вт, 16/01/2024 - 00:31 ответить
    Йо, всем привет, писал по поводу того, что не работает кнопка интерактива в игре Уведомлю, просто чтобы не мутить воду, это я идиот, который не поставил аддон для QoL С ним всё исправно
  • Alt
    MelonLoader обновлен до версии 0.6.2 Open-Beta
  • Alt
    С новой версией MelonLoader 0.6.2 возникли сложности и большинство модов сейчас выпускают с расчетом на предыдущую версию - 0.6.1. До решения проблем, рекомендуется пока не обновлять MelonLoader или вернуть предыдущую версию.
  • Alt
    а
    сб, 16/03/2024 - 10:43 ответить
    Вылезает ошибка it was not to possible to find comfortible framework version

Оставить комментарий